Monday, June 5, 2023 5:37:09 AM

Firmware Updating Instructions

8 months ago
#257148 Quote
See the link below for instructions on updating your Adapter's firmware.

Firmware Update Link
7 months ago
#259214 Quote
The update of my "6-Pin J1708 Adapter" firmware has been thwarted by my Windows 10 machine not identifying the adapter through the USB connection.
The USB driver is not automatically installed as it does for other USB devices.

Is there a driver for Windows 10 that is recommended for this device? If so, please provide the driver's name or possibly even a link to get it installed.

Your help is urgently needed as the adapter is stuck in update mode and will not allow normal operations.
7 months ago
#259242 Quote
There is no standard Windows driver. You have to follow the instructions in the Getting Started document's Firmware Update section exactly and to the letter.
7 months ago
#259249 Quote
I followed instructions and Win 10 will not load driver. Need the driver!
Randy Lust
7 months ago
#259250 Quote
If you can't install the driver from the Firmware Update instructions in the Getting Started document then you need to send your adapter in for update.
3 months ago
#261418 Quote
When I try to update my firmware, all blinks as it should and I run the program and get this message that it's unable to download the files, needs an internet connection. I clearly have a connection.

Any suggestions?, I have tried different cables, turned off WiFi & back on, connected to a different server on WiFi and back.....nothing changes

9 Pin 3.1.0 , Current firmware ver. 3.21.0, software 9.7.4

Thanks in advance
3 months ago
#261419 Quote
The firmware files are downloaded using FTP (File Transfer Protocol). You may need to set your Internet connection to allow FTP download (search Google for how to do this).
2 months ago
#261438 Quote

I'm currently on firmware 3.22.1.... my app updated to the latest, so I guess I need a firmware update.

Same problem as others have reported - the usb drivers for the adapter don't install.  The adapter does show up in device manager.

This is under the latest version of Win10pro.... it's a pretty clean install as I just use it for these types of things (Bluefire, Scanner, car programming, etc.)

Yes, I have followed the instruction exactly. I have tried about a bajillion USB cables, tried to install diver manually (navigating to the "drivers" folder should do it, eh? but it doesn't)....

Anyway to get a driver for this, so the firmware update can happen? For whatever reason, this wasn't a problem with 3.22.1, but now it is. No idea why. I did install the 3.22.1 on a different PC (that I don't have access to at the moment), so the firmware updater has never been installed on this PC.

Would just be nice to get the driver so I can do this.

3 weeks ago
#261459 Quote
I have done several past updates on my Win7 desktop, but no go on this new version.  It immediately failed with a 'This program won't run on this computer' message (or similar).  So.. I had to go find another .. fortunately I have a new Win11/Home laptop and was able to connect to the dongle with it and then click on the firmware update link and all proceeded as expected after that.  I would presume that Win10 would also work.
2 weeks ago
#261461 Quote
I have the adapter for motor coaches and bought it 6-13-21 through Amazon.  It has worked great and still is, but I keep getting a notice to upgrade the firmware.  It looks like some adapters need to be sent in to update the firmware.  Questions:
1) How do I find out what version of firmware my adapter has?
2) If I send it in, about how long will it take to get it back?