logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
BCNU  
#1 Posted : Saturday, October 2, 2021 12:50:49 PM(UTC)
BCNU

Rank: Newbie

Groups: Registered
Joined: 4/11/2021(UTC)
Posts: 5
United States
Location: 80602

mine is telling me the motor is 6Lu17D0890000000

the motor is in fact a Cummins L9

9 liter and not a 6L
Mark  
#2 Posted : Saturday, October 2, 2021 1:51:18 PM(UTC)
Mark

Rank: Administration

Groups: Administrators
Joined: 4/12/2014(UTC)
Posts: 653

Was thanked: 12 time(s) in 10 post(s)
The data is coming from the ECM. Most likely the engine or ECM was changed out and not reprogrammed.
BCNU  
#3 Posted : Saturday, October 2, 2021 2:50:29 PM(UTC)
BCNU

Rank: Newbie

Groups: Registered
Joined: 4/11/2021(UTC)
Posts: 5
United States
Location: 80602

thanks for the reply. to the best of my knowledge neither the engine or the ecm have been changed.
I knew it had an L9 motor and then noticed the data for the engine shows L6 and did not know if it was a setting I needed to set but guess not. will have to have the dealer look into it sometime.
I took a picture of the screen but can not find a way to attach it here
thanks
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.