logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Michael Grenert  
#1 Posted : Monday, March 8, 2021 10:23:43 AM(UTC)
Michael Grenert

Rank: Newbie

Groups: Registered
Joined: 3/8/2021(UTC)
Posts: 1
United States
Location: California

Newbie here.
2004 Cummins 300 ISB
Engine running
Bluefire shows connected, gauges show NA
Using IPhone.
What did I miss on set up?
Coalminer333  
#2 Posted : Thursday, March 18, 2021 12:24:47 PM(UTC)
Coalminer333

Rank: Newbie

Groups: Registered
Joined: 3/17/2021(UTC)
Posts: 3
United States
Location: PA

I have a 2007 Freightliner XC National Tropical Cummins 5.9 ISB. I set up BlueFire as a backup to the Light Bar Control Unit (LBCU) which feeds the dash gauges after it failed during a trip. I replaced the LBCU and set up a Bluefire Dashboard at the same time. I get most of the important data but air pressure and fuel level show NA. Following is my understanding how it works. I'm hoping Mark or somebody on the forum can confirm it. The data is fed from ECU's that monitor such parameters as coolant temperature, voltage, oil pressure, etc. to a two wire CAN bus that feeds the LBCU and the diagnostics ports (such as J1939 black 6 pin on older models and J1939 green 9 pin on newer models). The LBCU then sends the signals to the dash gauges. If the LBCU fails, you lose the dash gauges but the CAN bus (from which BlueFire and the diagnostic ports receives their data) are still available. In my case, it appears that air pressure and fuel tank level are not ECU's that feed the CAN bus and therefore the data is not available in BlueFire. I learned that you can determine which data is available on the CAN bus for use in BlueFire by opening the "Repair" window within BlueFire (with the engine running) and recording all of the parameters that do not show "NA". Any parameters that show "NA" are not available on the CAN bus and therefore won't display within the BlueFire program. As a side note; when I replaced the LBCU I noticed that the LBCU feeds the speedo, tacho, voltage, oil press and coolant temperature via a daisy chain wiring setup. But, the two air pressure gauges and the fuel tank level (which show NA within BlueFire) are connected to the LBCU via a separate daisy chain. In addition, the air gauges are plumbed directly to the air system via high pressure tubing that runs into the cab. So, I'm assuming that the air system data (and apparently the fuel tank level data) is not fed to the CAN bus but rather are measured directly and fed to the LBCU and finally the dash gauges but not the CAN bus. You might also want to check out the IRV2 Forum where we have had some additional discussion.
Mark  
#3 Posted : Thursday, March 18, 2021 2:42:37 PM(UTC)
Mark

Rank: Administration

Groups: Administrators
Joined: 4/12/2014(UTC)
Posts: 656

Was thanked: 12 time(s) in 10 post(s)
You got it. It does look like your air pressure and fuel tank sensor are not tied into a CAN bus ECU so we cannot retrieve and display it.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.